Submitted by 熊茂祥 on 2015, May 14, 11:48 AM
ROS脚本
- #DDNS Token-ID
- :global tid "10002"
- #DDNS Token
- :global tsn "85c4cece0ced14dba4837d13c2cab0e0"
- #DDNS域名
- :global rhost "域名(例如www.cat-home.org)"
- #以下不需要修改
- :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]
- :global zhost [:pick $rhost 0 [:find $rhost "."]]
- /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") mode=http keep-result=no
DNSPOD Token申请地址
https://support.dnspod.cn/Kb/showarticle/tsid/227/
» 阅读全文
Tags: dnspod, ddns, 脚本, 多线, adsl
ROS | 评论:7
| 阅读:35427
Submitted by 熊茂祥 on 2014, September 2, 12:58 PM
ROS脚本
- #DDNS帐号
- :global user "用户名"
- #DDNS密码
- :global pass "密码"
- #DDNS域名
- :global rhost "域名(例如www.cat-home.org)"
- #以下不需要修改
- :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]
- :global zhost [:pick $rhost 0 [:find $rhost "."]]
- /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?user=$user&passwd=$pass&ym=$host&zym=$zhost") mode=http keep-result=no
- }
懒得说明,不会用自己面壁去。
» 阅读全文
Tags: dnspod, ddns, 脚本, 多线, adsl
ROS | 评论:1
| 阅读:46020
Submitted by 熊茂祥 on 2012, September 14, 11:51 AM
DDNS脚本自动绑定到默认路由的接口更新IP
:global ddnsuser "用户名"
:global ddnspass "密码"
:global ddnshost "域名"
:global gate [/ip route get [/ip route find static=yes active=yes dynamic=yes distance=1] gateway]
:global ddnsinterface {:put [/ip add get [find network=$gate] interface]}
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass
» 阅读全文
Tags: ros, adsl, 多线, ddns, 脚本
ROS | 评论:0
| 阅读:33626
Submitted by 熊茂祥 on 2012, September 14, 11:45 AM
映射脚本自动绑定到默认路由的接口更新IP
--------------对NAT规则备注名进行查找-----------------
:global adcmname "3389"
:global adgw [/ip route get [/ip route find static=yes active=yes dynamic=yes distance=1] gateway]
:global ip [/ip add get [find network=$adgw] address]
:global newip [:pick $ip 0 [:find $ip "/"]]
:global oldip [/ip fi nat get [/ip fi nat find comment=$adcmname] dst-address]
:if ($newip != $oldip) do={
:log info [/ip fi nat set [/ip firewall nat find comment=$adcmname] dst-address=$newip]
}
» 阅读全文
Tags: ros, adsl, 多线, 映射, 脚本
ROS | 评论:0
| 阅读:35545