让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆

全部评论

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

引用 charwin 说过的话:
:do [/tool fetch url=\"https://dnsapi.cn/Record.Info\" http-data=\"login_token=$myToken&format=json&domain_id=$domainId&record_id=$recordId\"]
:delay 5s
:local dnspodf [/file get [find name=\"Record.Info\"] contents]
:local num1 [:find $dnspodf value]
:local num2 [:find $dnspodf weight]
:local fdend [:pick $dnspodf ($num1 + 8) (num2 - 3)]
域名记录查IP 这样 是不是 更快呢

感谢提供参考,但是目前没有更新计划哦。

Post by 熊茂祥 on 2021, April 19, 11:16 PM

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

:do [/tool fetch url=\"https://dnsapi.cn/Record.Info\" http-data=\"login_token=$myToken&format=json&domain_id=$domainId&record_id=$recordId\"]
:delay 5s
:local dnspodf [/file get [find name=\"Record.Info\"] contents]
:local num1 [:find $dnspodf value]
:local num2 [:find $dnspodf weight]
:local fdend [:pick $dnspodf ($num1 + 8) (num2 - 3)]

域名记录查IP 这样 是不是 更快呢

Post by charwin on 2021, April 4, 6:36 PM

ROS云变量服务(已开放)

就是高手,一下,就好了,全部能正常运行了。感谢。[quote=熊茂祥][/quote]

Post by 偶然 on 2021, March 1, 8:04 PM

ROS云变量服务(已开放)

引用 oyran 说过的话:
:log warning $gettestbl   从云上得到另一地方IP地址。显示地址正常。
:global oldgettestbl [/interface gre get gre-tunnel2 value-name=remote-address]   从本机得到老的地址,
:log warning $oldgettestbl    显示老的地址,
:if ($gettestbl != $oldgettestbl) do= {/interface gre set gre-tunnel2 remote-address=$gettestbl   判断新地址与老地址是否一样,不一样进行更改地址,就这一步就出错了,一改地址,就变成了0.0.0.0,希望帮忙看看那里有问题。
:log warning \"地址更换完成\"
} else={
:log warning \"地址一样不需要更换\"}
自己在命令行上直接手动打  interface gre set gre-tunnel2 remote-address=$gettestbl 这条命令就能直接更换成IP地址。放到脚本里面就成0.0.0.0
熊哥,麻烦您给看看,指点一下问题出在了那里。谢谢了。

:global $gettestbl
以上放到第一行即可,调用变量需要先申明。

Post by 熊茂祥 on 2021, February 25, 10:11 AM

ROS云变量服务(已开放)

:log warning $gettestbl   从云上得到另一地方IP地址。显示地址正常。

:global oldgettestbl [/interface gre get gre-tunnel2 value-name=remote-address]   从本机得到老的地址,
:log warning $oldgettestbl    显示老的地址,

:if ($gettestbl != $oldgettestbl) do= {/interface gre set gre-tunnel2 remote-address=$gettestbl   判断新地址与老地址是否一样,不一样进行更改地址,就这一步就出错了,一改地址,就变成了0.0.0.0,希望帮忙看看那里有问题。

:log warning \"地址更换完成\"
} else={
:log warning \"地址一样不需要更换\"}

自己在命令行上直接手动打  interface gre set gre-tunnel2 remote-address=$gettestbl 这条命令就能直接更换成IP地址。放到脚本里面就成0.0.0.0

熊哥,麻烦您给看看,指点一下问题出在了那里。谢谢了。

Post by oyran on 2021, February 24, 12:42 PM

为何需要维护外包

引用 sun880213 说过的话:
怎么联系你呢szz880213

微信x9939781

Post by 熊茂祥 on 2021, February 16, 11:48 PM

新建微信通知中心(公测)

引用 偶然 说过的话:
能提供个示例嘛?

脚本示例文章里有哦

Post by 熊茂祥 on 2021, February 16, 11:47 PM

为何需要维护外包

怎么联系你呢szz880213

Post by sun880213 on 2021, February 15, 12:36 PM

某境外ISP维护案例

感觉就是高手,现在刚研究明白OSPF,但MPLS就彻底不明白了。崩溃中。

Post by 偶然 on 2021, February 12, 8:57 PM

新建微信通知中心(公测)

能提供个示例嘛?

Post by 偶然 on 2021, February 12, 8:24 PM

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

引用 等待 说过的话:
问题不知道为啥,这脚本填写了我自己对应的信息后直接粘贴在PPP-ON模板里在对应外网重拨时没有牵引触发执行,log中也没看到提示,所以我才觉得是脚本问题还是版本问题,6.48的X86和CCR还有RB版本都试过,我专门建立了一个模版,并且让对应的外网拨号使用此模版拨号,昨晚给你留言之前我本身的命令就是sys scr run dsnpod  非常感谢大猫的回复

看看日志情况呢,联系微信x9939781联系我发日志截图排查

Post by 熊茂祥 on 2021, January 21, 10:24 PM

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

问题不知道为啥,这脚本填写了我自己对应的信息后直接粘贴在PPP-ON模板里在对应外网重拨时没有牵引触发执行,log中也没看到提示,所以我才觉得是脚本问题还是版本问题,6.48的X86和CCR还有RB版本都试过,我专门建立了一个模版,并且让对应的外网拨号使用此模版拨号,昨晚给你留言之前我本身的命令就是sys scr run dsnpod  非常感谢大猫的回复

Post by 等待 on 2021, January 21, 3:47 AM

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

引用 等待 说过的话:
这个脚本直接放在ppp模版中是无效的,把这个脚本放在sys-script中,在ppp的模版中执行sys scr run number=0  也不行,是不是可以添加一个自动检测对应域名对应线路IP对照,IP变动就自动运行sys scr run number=0  ,ip未变动则不运行sys scr run number=0  ???

脚本直接粘贴在PPP-ON模板里,让拨号引用这个模板即可。引用外部脚本你的语法错误,sys scr run xxx即可

Post by 熊茂祥 on 2021, January 20, 10:07 AM

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

这个脚本直接放在ppp模版中是无效的,把这个脚本放在sys-script中,在ppp的模版中执行sys scr run number=0  也不行,是不是可以添加一个自动检测对应域名对应线路IP对照,IP变动就自动运行sys scr run number=0  ,ip未变动则不运行sys scr run number=0  ???

Post by 等待 on 2021, January 20, 4:11 AM

穿透内网管理&云交换自助服务

引用 好 说过的话:
熊大这么多年过去了,你还在弄这,真是专业,厉害,都忘了搜啥搜到这网站的,新年快乐

新年快乐老朋友~希望新的一年里一切顺利!我将会继续努力带来更多新产品,当然也包含免费公益项目。

Post by 熊茂祥 on 2021, January 17, 11:55 AM

穿透内网管理&云交换自助服务

熊大这么多年过去了,你还在弄这,真是专业,厉害,都忘了搜啥搜到这网站的,新年快乐

Post by 好 on 2021, January 16, 1:37 PM

本站开通可和ROS对接的任意认证radius服务

引用 zhangying 说过的话:
这个还能用吗

可以正常使用哦

Post by 熊茂祥 on 2020, December 29, 10:52 AM

本站开通可和ROS对接的任意认证radius服务

这个还能用吗

Post by zhangying on 2020, December 28, 11:10 PM

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

引用 rosuser 说过的话:
此脚本近期出现问题,无法更新。
后端dnspod上删除aaa主机后发现无法增加。老版v4正常。
之前一直工作正常。近期重启后无法使用。单v4的没问题。但是缺少接口定义。

已经发现获取域名列表的keyword函数执行不正常,已经提交工单转交腾讯处理。

Post by 熊茂祥 on 2020, December 21, 6:41 PM

新建ROS的DNSPOD脚本更新项目(2020/12/21更新)

dnspod api 又更新了,代码已失效,麻烦更新下,谢谢了!!!

Post by gengjingfeng on 2020, December 20, 6:15 PM

Records:35312345678910»